<!doctype html >
<html lang="en-US">
<head>
<meta charset="UTF-8" />
<title>Ramogi TV live &ndash; Kenyan News</title><link rel="preload" as="font" href="https://fonts.gstatic.com/s/montserrat/v25/JTUSjIg1_i6t8kCHKm459Wlhyw.woff2" crossorigin><link rel="preload" as="font" href="https://fonts.gstatic.com/s/opensans/v34/memvYaGs126MiZpBA-UvWbX2vVnXBbObj2OVTS-muw.woff2" crossorigin><link rel="preload" as="font" href="https://fonts.gstatic.com/s/roboto/v30/KFOmCnqEu92Fr1Mu4mxK.woff2" crossorigin><link rel="preload" as="font" href="https://fonts.gstatic.com/s/roboto/v30/KFOlCnqEu92Fr1MmEU9fBBc4.woff2" crossorigin><link rel="preload" as="font" href="https://fonts.gstatic.com/s/roboto/v30/KFOlCnqEu92Fr1MmWUlfBBc4.woff2" crossorigin><link rel="preload" as="font" href="https://kenyannews.co.ke/wp-content/themes/Newspaper/images/icons/newspaper.woff?21" crossorigin><style id="wpr-usedcss">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</style>
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="pingback" href="https://kenyannews.co.ke/xmlrpc.php" />
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

<meta name="google-site-verification" content="M4dJ9kYdk9UN5sQYHbWh4YxcQ6e03PSJMdpg3u2VUjU" />
<meta name="msvalidate.01" content="1F7347794692215F920332B3E2E44BDE" />
<meta name="yandex-verification" content="2586545c00aab891" />
<link rel="icon" type="image/png" href="https://kenyannews.co.ke/wp-content/uploads/2017/07/kfav-small.png">

<link rel="canonical" href="https://kenyannews.co.ke/tv/ramogi-tv-live/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Ramogi TV live" />
<meta property="og:description" content="Ramogi TV live stream. Kenya&#8217;s Premier Dholuo TV Station." />
<meta property="og:url" content="https://kenyannews.co.ke/tv/ramogi-tv-live/" />
<meta property="og:site_name" content="Kenyan news: Latest news in Kenya, Africa, World in real time" />
<meta property="article:publisher" content="https://www.facebook.com/kenyannews.co.ke/" />
<meta property="article:published_time" content="2022-10-13T08:23:14+00:00" />
<meta property="article:modified_time" content="2022-10-13T08:29:30+00:00" />
<meta property="og:image" content="https://kenyannews.co.ke/wp-content/uploads/2022/10/ramogitv.jpg" />
<meta property="og:image:width" content="890" />
<meta property="og:image:height" content="580" />
<meta property="og:image:type" content="image/jpeg" />
<meta name="author" content="kenyan" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@kenyannews_" />
<meta name="twitter:site" content="@kenyannews_" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="kenyan" />
<meta name="twitter:label2" content="Est. reading time" />
<meta name="twitter:data2" content="1 minute" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Article","@id":"https://kenyannews.co.ke/tv/ramogi-tv-live/#article","isPartOf":{"@id":"https://kenyannews.co.ke/tv/ramogi-tv-live/"},"author":{"name":"kenyan","@id":"https://kenyannews.co.ke/#/schema/person/3b6840a744a3c01cf298b4a93e776dd3"},"headline":"Ramogi TV live","datePublished":"2022-10-13T08:23:14+00:00","dateModified":"2022-10-13T08:29:30+00:00","mainEntityOfPage":{"@id":"https://kenyannews.co.ke/tv/ramogi-tv-live/"},"wordCount":38,"publisher":{"@id":"https://kenyannews.co.ke/#organization"},"image":{"@id":"https://kenyannews.co.ke/tv/ramogi-tv-live/#primaryimage"},"thumbnailUrl":"https://kenyannews.co.ke/wp-content/uploads/2022/10/ramogitv.jpg","articleSection":["TV"],"inLanguage":"en-US","copyrightYear":"2022","copyrightHolder":{"@id":"https://kenyannews.co.ke/#organization"}},{"@type":"WebPage","@id":"https://kenyannews.co.ke/tv/ramogi-tv-live/","url":"https://kenyannews.co.ke/tv/ramogi-tv-live/","name":"Ramogi TV live &ndash; Kenyan News","isPartOf":{"@id":"https://kenyannews.co.ke/#website"},"primaryImageOfPage":{"@id":"https://kenyannews.co.ke/tv/ramogi-tv-live/#primaryimage"},"image":{"@id":"https://kenyannews.co.ke/tv/ramogi-tv-live/#primaryimage"},"thumbnailUrl":"https://kenyannews.co.ke/wp-content/uploads/2022/10/ramogitv.jpg","datePublished":"2022-10-13T08:23:14+00:00","dateModified":"2022-10-13T08:29:30+00:00","breadcrumb":{"@id":"https://kenyannews.co.ke/tv/ramogi-tv-live/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://kenyannews.co.ke/tv/ramogi-tv-live/"]}]},{"@type":"ImageObject","inLanguage":"en-US","@id":"https://kenyannews.co.ke/tv/ramogi-tv-live/#primaryimage","url":"https://kenyannews.co.ke/wp-content/uploads/2022/10/ramogitv.jpg","contentUrl":"https://kenyannews.co.ke/wp-content/uploads/2022/10/ramogitv.jpg","width":890,"height":580},{"@type":"BreadcrumbList","@id":"https://kenyannews.co.ke/tv/ramogi-tv-live/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://kenyannews.co.ke/"},{"@type":"ListItem","position":2,"name":"TV","item":"https://kenyannews.co.ke/tv/"},{"@type":"ListItem","position":3,"name":"Ramogi TV live"}]},{"@type":"WebSite","@id":"https://kenyannews.co.ke/#website","url":"https://kenyannews.co.ke/","name":"Kenyan news: Latest news in Kenya, Africa, World in real time","description":"Kenya news and opinion website that brings you current reports and news from Kenya, Africa, World. Stay updated with latest, breaking news and current affairs.","publisher":{"@id":"https://kenyannews.co.ke/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://kenyannews.co.ke/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"Organization","@id":"https://kenyannews.co.ke/#organization","name":"Kenyan News","url":"https://kenyannews.co.ke/","sameAs":["https://instagram.com/kenyannews.co.ke","https://www.facebook.com/kenyannews.co.ke/","https://twitter.com/kenyannews_"],"logo":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://kenyannews.co.ke/#/schema/logo/image/","url":"","contentUrl":"","caption":"Kenyan News"},"image":{"@id":"https://kenyannews.co.ke/#/schema/logo/image/"}},{"@type":"Person","@id":"https://kenyannews.co.ke/#/schema/person/3b6840a744a3c01cf298b4a93e776dd3","name":"kenyan","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://kenyannews.co.ke/#/schema/person/image/","url":"https://secure.gravatar.com/avatar/6c0e6a82169ee878dcbc43393803b843?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/6c0e6a82169ee878dcbc43393803b843?s=96&d=mm&r=g","caption":"kenyan"},"url":"https://kenyannews.co.ke/author/kenyan/"}]}</script>

<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//www.googletagmanager.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<link rel='dns-prefetch' href='//i3.wp.com' />
<link rel='dns-prefetch' href='//googleads.g.doubleclick.net' />
<link rel='dns-prefetch' href='//fonts.gstatic.com' />
<link rel='dns-prefetch' href='//cm.g.doubleclick.net' />
<link rel='dns-prefetch' href='//www.sport.es' />
<link rel='dns-prefetch' href='//www.01net.com' />
<link rel='dns-prefetch' href='//tecnoblog.net' />
<link rel='dns-prefetch' href='//noticias.uol.com.br' />
<link rel='dns-prefetch' href='//hellosehat.com' />
<link rel='dns-prefetch' href='//www.minhavida.com.br' />
<link rel='dns-prefetch' href='//www.footmercato.net' />
<link rel='dns-prefetch' href='//www.google-analytics.com' />
<link rel='dns-prefetch' href='//jsc.mgid.com' />
<link rel='dns-prefetch' href='//stats.wp.com' />
<link rel='dns-prefetch' href='//ajax.cloudflare.com' />
<link rel='dns-prefetch' href='//tpc.googlesyndication.com' />
<link rel='dns-prefetch' href='//pagead2.googlesyndication.com' />
<link rel='dns-prefetch' href='//maps.googleapis.com' />
<link rel='dns-prefetch' href='//maps.gstatic.com' />
<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//apis.google.com' />
<link rel='dns-prefetch' href='//google-analytics.com' />
<link rel='dns-prefetch' href='//ssl.google-analytics.com' />
<link rel='dns-prefetch' href='//youtube.com' />
<link rel='dns-prefetch' href='//api.pinterest.com' />
<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//pixel.wp.com' />
<link rel='dns-prefetch' href='//connect.facebook.net' />
<link rel='dns-prefetch' href='//platform.twitter.com' />
<link rel='dns-prefetch' href='//syndication.twitter.com' />
<link rel='dns-prefetch' href='//platform.instagram.com' />
<link rel='dns-prefetch' href='//disqus.com' />
<link rel='dns-prefetch' href='//sitename.disqus.com' />
<link rel='dns-prefetch' href='//s7.addthis.com' />
<link rel='dns-prefetch' href='//platform.linkedin.com' />
<link rel='dns-prefetch' href='//w.sharethis.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//s.gravatar.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="Kenyan news: Latest news in Kenya, Africa, World in real time &raquo; Feed" href="https://kenyannews.co.ke/feed/" />
<link rel="alternate" type="application/rss+xml" title="Kenyan news: Latest news in Kenya, Africa, World in real time &raquo; Comments Feed" href="https://kenyannews.co.ke/comments/feed/" />
<style type="text/css"></style>
<style id='wp-block-library-inline-css' type='text/css'></style>
<style id='global-styles-inline-css' type='text/css'></style>
<style id='td-theme-inline-css' type='text/css'></style>
<script type='text/javascript' src='https://kenyannews.co.ke/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>

<script type='text/javascript' src='https://www.googletagmanager.com/gtag/js?id=UA-92634106-1' id='google_gtagjs-js' async></script>
<script type='text/javascript' id='google_gtagjs-js-after'>
window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('set', 'linker', {"domains":["kenyannews.co.ke"]} );
gtag("js", new Date());
gtag("set", "developer_id.dZTNiMT", true);
gtag("config", "UA-92634106-1", {"anonymize_ip":true});
</script>

<link rel="https://api.w.org/" href="https://kenyannews.co.ke/wp-json/" /><link rel="alternate" type="application/json" href="https://kenyannews.co.ke/wp-json/wp/v2/posts/914448" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://kenyannews.co.ke/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://kenyannews.co.ke/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 6.0.2" />
<link rel='shortlink' href='https://wp.me/p7EBuU-3PTa' />
<link rel="alternate" type="application/json+oembed" href="https://kenyannews.co.ke/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fkenyannews.co.ke%2Ftv%2Framogi-tv-live%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://kenyannews.co.ke/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fkenyannews.co.ke%2Ftv%2Framogi-tv-live%2F&#038;format=xml" />
<meta name="generator" content="Site Kit by Google 1.85.0" /><style></style>
<!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
<script>
        window.tdb_globals = {"wpRestNonce":"15ead4fad2","wpRestUrl":"https:\/\/kenyannews.co.ke\/wp-json\/","permalinkStructure":"\/%category%\/%postname%\/","globalSettings":{"tdcSavingHistory":"false"},"isAjax":false,"isAdminBarShowing":false,"autoloadScrollPercent":50,"postAutoloadStatus":"off","origPostEditUrl":null};
    </script>
<style id="tdb-global-colors"></style>
<script>
				window.tdwGlobal = {"adminUrl":"https:\/\/kenyannews.co.ke\/wp-admin\/","wpRestNonce":"15ead4fad2","wpRestUrl":"https:\/\/kenyannews.co.ke\/wp-json\/","permalinkStructure":"\/%category%\/%postname%\/"};
			</script>
<script>
        window.tdaGlobal = {"adminUrl":"https:\/\/kenyannews.co.ke\/wp-admin\/","wpRestNonce":"15ead4fad2","wpRestUrl":"https:\/\/kenyannews.co.ke\/wp-json\/","permalinkStructure":"\/%category%\/%postname%\/","postId":224827};
    </script>

<meta name="google-adsense-platform-account" content="ca-host-pub-2644536267352236">
<meta name="google-adsense-platform-domain" content="sitekit.withgoogle.com">


<script async="async" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-3264247487734791" crossorigin="anonymous" type="text/javascript"></script>


<script>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</script>

<style></style>
<script>
(function(i,s,o,g,r,a,m)
{i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new 
Date();a=s.createElement(o),m=s.getElementsByTagName(o)
[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','
https://www.google-analytics.com/analytics.js','ga');

ga('create', 'UA-92634106-1', 'auto');
ga('send', 'pageview');
</script>
<script data-ad-client="ca-pub-3264247487734791" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script data-ad-client="ca-pub-5011174329758173" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<link rel="icon" href="https://kenyannews.co.ke/wp-content/uploads/2022/10/kfav-small.png" sizes="32x32" />
<link rel="icon" href="https://kenyannews.co.ke/wp-content/uploads/2022/10/kfav-small.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://kenyannews.co.ke/wp-content/uploads/2022/10/kfav-small.png" />
<meta name="msapplication-TileImage" content="https://kenyannews.co.ke/wp-content/uploads/2022/10/kfav-small.png" />

<style>
    
</style>
<style id="tdw-css-placeholder"></style><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript></head>
<body data-rsssl=1 class="post-template-default single single-post postid-914448 single-format-video tdm-menu-active-style5 ramogi-tv-live global-block-template-1 tdb_template_255853 tdb-template  tdc-header-template  tdc-footer-template td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">
<div class="td-scroll-up  td-hide-scroll-up-on-mob" style="display:none;"><i class="td-icon-menu-up"></i></div>
<div class="td-menu-background" style="visibility:hidden"></div>
<div id="td-mobile-nav" style="visibility:hidden">
<div class="td-mobile-container">

<div class="td-menu-socials-wrap">

<div class="td-menu-socials">
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.facebook.com/kenyannews.co.ke" title="Facebook">
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.instagram.com/kenyannews.co.ke/" title="Instagram">
<i class="td-icon-font td-icon-instagram"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://twitter.com/kenyannews_" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="#" title="Vimeo">
<i class="td-icon-font td-icon-vimeo"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="#" title="Youtube">
<i class="td-icon-font td-icon-youtube"></i>
</a>
</span> </div>

<div class="td-mobile-close">
<a href="#" aria-label="Close"><i class="td-icon-close-mobile"></i></a>
</div>
</div>


<div class="td-mobile-content">
<div class="menu-header-menu-container"><ul id="menu-header-menu" class="td-mobile-main-menu"><li id="menu-item-216189" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-first menu-item-216189"><a href="https://kenyannews.co.ke/news/">News<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-12022" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12022"><a href="https://kenyannews.co.ke/news/politics/">Politics</a></li>
<li id="menu-item-12024" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12024"><a href="https://kenyannews.co.ke/news/county-news/">County news</a></li>
<li id="menu-item-12023" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12023"><a href="https://kenyannews.co.ke/news/africa-news/">Africa</a></li>
<li id="menu-item-12026" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12026"><a href="https://kenyannews.co.ke/world-news/">World news</a></li>
</ul>
</li>
<li id="menu-item-241088" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-241088"><a href="https://kenyannews.co.ke/entertainment/">Entertainment</a></li>
<li id="menu-item-12028" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12028"><a href="https://kenyannews.co.ke/health/">Health</a></li>
<li id="menu-item-127" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-127"><a href="https://kenyannews.co.ke/sports/">Sports</a></li>
<li id="menu-item-357907" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-357907"><a href="https://kenyannews.co.ke/videos/">Videos</a></li>
<li id="menu-item-126" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-126"><a href="https://kenyannews.co.ke/radio/">Radio</a></li>
<li id="menu-item-129" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-129"><a href="https://kenyannews.co.ke/tv/">TV</a></li>
</ul></div> </div>
</div>

</div> <div class="td-search-background" style="visibility:hidden"></div>
<div class="td-search-wrap-mob" style="visibility:hidden">
<div class="td-drop-down-search">
<form method="get" class="td-search-form" action="https://kenyannews.co.ke/">

<div class="td-search-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
<div role="search" class="td-search-input">
<span>Search</span>
<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
</div>
</form>
<div id="td-aj-search-mob" class="td-ajax-search-flex"></div>
</div>
</div>
<div id="td-outer-wrap" class="td-theme-wrap">
<div class="td-header-template-wrap" style="position: relative">
<div class="td-header-mobile-wrap ">
<div id="tdi_1" class="tdc-zone"><div class="tdc_zone tdi_2  wpb_row td-pb-row">
<style scoped></style><div id="tdi_3" class="tdc-row"><div class="vc_row tdi_4 td-reel-news-blur-bg wpb_row td-pb-row tdc-element-style">
<style scoped></style>
<div class="tdi_3_rand_style td-element-style"><div class="td-element-style-before"><style></style></div><style></style></div><div class="vc_column tdi_6  wpb_column vc_column_container tdc-column td-pb-span6">
<style scoped></style><div class="wpb_wrapper"><div class="td_block_wrap tdb_header_logo tdi_7 td-pb-border-top td_block_template_1 tdb-header-align" data-td-block-uid="tdi_7">
<style></style>
<style></style><div class="tdb-block-inner td-fix-index"><a class="tdb-logo-a" href="https://kenyannews.co.ke/"><span class="tdb-logo-img-wrap"><img class="tdb-logo-img" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20272%2090'%3E%3C/svg%3E" alt="Kenyan News | Latest Kenya news, Africa, World Breaking news | Live Tv, Radio | Videos" title="" width="272" height="90" data-lazy-src="https://kenyannews.co.ke/wp-content/uploads/2022/10/kenyannews.co_.kemobile-logo-1.png" /><noscript><img class="tdb-logo-img" src="https://kenyannews.co.ke/wp-content/uploads/2022/10/kenyannews.co_.kemobile-logo-1.png" alt="Kenyan News | Latest Kenya news, Africa, World Breaking news | Live Tv, Radio | Videos"  title=""  width="272" height="90" /></noscript></span></a></div></div> </div></div><div class="vc_column tdi_9  wpb_column vc_column_container tdc-column td-pb-span6">
<style scoped></style><div class="wpb_wrapper"><div class="td_block_wrap tdb_mobile_search tdi_10 td-pb-border-top td_block_template_1 tdb-header-align" data-td-block-uid="tdi_10">
<style></style><div class="tdb-block-inner td-fix-index"><a class="tdb-header-search-button-mob dropdown-toggle" href="#" role="button" aria-label="Search" data-toggle="dropdown"><i class="tdb-mobile-search-icon td-icon-search"></i></a></div></div> <div class="td_block_wrap tdb_mobile_menu tdi_11 td-pb-border-top td_block_template_1 tdb-header-align" data-td-block-uid="tdi_11">
<style></style>
<style></style><div class="tdb-block-inner td-fix-index"><a class="tdb-mobile-menu-button" aria-label="menu-button" href="#"><i class="tdb-mobile-menu-icon td-icon-mobile"></i></a></div></div> </div></div></div></div></div></div> </div>
<div class="td-header-mobile-sticky-wrap tdc-zone-sticky-invisible tdc-zone-sticky-inactive" style="display: none">
<div id="tdi_12" class="tdc-zone"><div class="tdc_zone tdi_13  wpb_row td-pb-row" data-sticky-offset="0">
<style scoped></style><div id="tdi_14" class="tdc-row"><div class="vc_row tdi_15  wpb_row td-pb-row">
<style scoped></style><div class="vc_column tdi_17  wpb_column vc_column_container tdc-column td-pb-span12">
<style scoped></style><div class="wpb_wrapper"></div></div></div></div></div></div> </div>
<div class="td-header-desktop-wrap ">
<div id="tdi_18" class="tdc-zone"><div class="tdc_zone tdi_19  wpb_row td-pb-row">
<style scoped></style><div id="tdi_20" class="tdc-row stretch_row"><div class="vc_row tdi_21 td-reel-news-blur-bg wpb_row td-pb-row tdc-element-style">
<style scoped></style>
<div class="tdi_20_rand_style td-element-style"><div class="td-element-style-before"><style></style></div><style></style></div><div class="vc_column tdi_23  wpb_column vc_column_container tdc-column td-pb-span4">
<style scoped></style><div class="wpb_wrapper"><div class="td_block_wrap tdb_header_logo tdi_24 td-pb-border-top td_block_template_1 tdb-header-align" data-td-block-uid="tdi_24">
<style></style><div class="tdb-block-inner td-fix-index"><a class="tdb-logo-a" href="https://kenyannews.co.ke/"><span class="tdb-logo-img-wrap"><img class="tdb-logo-img" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20272%2090'%3E%3C/svg%3E" alt="Kenyan News | Latest Kenya news, Africa, World Breaking news | Live Tv, Radio | Videos" title="" width="272" height="90" data-lazy-src="https://kenyannews.co.ke/wp-content/uploads/2022/10/kenyannews.co_.kemobile-logo-1.png" /><noscript><img class="tdb-logo-img" src="https://kenyannews.co.ke/wp-content/uploads/2022/10/kenyannews.co_.kemobile-logo-1.png" alt="Kenyan News | Latest Kenya news, Africa, World Breaking news | Live Tv, Radio | Videos"  title=""  width="272" height="90" /></noscript></span></a></div></div> </div></div><div class="vc_column tdi_26  wpb_column vc_column_container tdc-column td-pb-span4">
<style scoped></style><div class="wpb_wrapper"><div class="td_block_wrap tdb_header_menu tdi_27 tds_menu_active1 tds_menu_sub_active1 tdb-menu-items-in-more tdb-mm-align-screen td-pb-border-top td-reel-news-main-menu td_block_template_1 tdb-header-align" data-td-block-uid="tdi_27" style=" z-index: 999;">
<style></style>
<style></style>
<style></style><div id=tdi_27 class="td_block_inner td-fix-index"><div class="tdb-main-sub-icon-fake"><i class="tdb-sub-menu-icon td-icon-pluss tdb-main-sub-menu-icon"></i></div><div class="tdb-sub-icon-fake"><i class="tdb-sub-menu-icon td-icon-right-arrow"></i></div><div class="tdb-menu-items-pulldown tdb-menu-items-pulldown-inactive"><ul id="menu-footer" class="tdb-block-menu tdb-menu tdb-menu-items-visible"><li id="menu-item-913825" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent tdb-cur-menu-item menu-item-first tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-913825"><a href="https://kenyannews.co.ke/tv/"><div class="tdb-menu-item-text">TV</div></a></li>
<li id="menu-item-914249" class="menu-item menu-item-type-taxonomy menu-item-object-radio_country tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-914249"><a href="https://kenyannews.co.ke/country/ke/"><div class="tdb-menu-item-text">Radio stations</div></a></li>
<li id="menu-item-913826" class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-menu-item-button tdb-menu-item tdb-mega-menu tdb-mega-menu-inactive tdb-mega-menu-cats-first menu-item-913826"><a href="https://kenyannews.co.ke/news/"><div class="tdb-menu-item-text">News</div><i class="tdb-sub-menu-icon td-icon-pluss tdb-main-sub-menu-icon"></i></a>
<ul class="sub-menu">
<li id="menu-item-0" class="menu-item-0"><div class="tdb-menu-item-text"><div class="tdb_header_mega_menu tdi_28 td_with_ajax_pagination td-pb-border-top td-reel-news-main-menu td_block_template_1" data-td-block-uid="tdi_28">
<style></style><script>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</script><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-tdi_28" id="tdi_29" data-td_block_id="tdi_28" data-td_filter_value="" href="https://kenyannews.co.ke/news/">All</a><a class="mega-menu-sub-cat-tdi_28" id="tdi_30" data-td_block_id="tdi_28" data-td_filter_value="535" href="https://kenyannews.co.ke/news/africa-news/">Africa</a><a class="mega-menu-sub-cat-tdi_28" id="tdi_31" data-td_block_id="tdi_28" data-td_filter_value="14455" href="https://kenyannews.co.ke/news/breaking-news/">Breaking news</a><a class="mega-menu-sub-cat-tdi_28" id="tdi_32" data-td_block_id="tdi_28" data-td_filter_value="545" href="https://kenyannews.co.ke/news/county-news/">County news</a><a class="mega-menu-sub-cat-tdi_28" id="tdi_33" data-td_block_id="tdi_28" data-td_filter_value="13" href="https://kenyannews.co.ke/news/politics/">Politics</a></div><div class="tdb-mega-modules-wrap"><div id=tdi_28 class="td_block_inner">
<div class="tdb_module_header tdb_module_mm td_module_wrap td-animation-stack td-meta-info-hide td-cpt-post">
<div class="td-module-container td-category-pos-image">
<div class="td-image-container">
<div class="td-module-thumb"><a href="https://kenyannews.co.ke/news/using-tech-to-make-the-most-of-travel/" rel="bookmark" class="td-image-wrap " title="Using Tech to Make the Most of Travel"><span data-bg="" class="entry-thumb td-thumb-css rocket-lazyload" style=""></span></a></div> </div>
<div class="td-module-meta-info">
<h2 class="entry-title td-module-title"><a href="https://kenyannews.co.ke/news/using-tech-to-make-the-most-of-travel/" rel="bookmark" title="Using Tech to Make the Most of Travel">Using Tech to Make the Most of Travel</a></h2>
<div class="td-editor-date">
<span class="td-author-date">
</span>
</div>
</div>
</div>
</div>
<div class="tdb_module_header tdb_module_mm td_module_wrap td-animation-stack td-meta-info-hide td-cpt-post">
<div class="td-module-container td-category-pos-image">
<div class="td-image-container">
<div class="td-module-thumb"><a href="https://kenyannews.co.ke/news/is-messis-magic-wand-still-in-full-working-order/" rel="bookmark" class="td-image-wrap " title="Is Messi’s magic wand still in full working order?"><span data-bg="" class="entry-thumb td-thumb-css rocket-lazyload" style=""></span></a></div> </div>
<div class="td-module-meta-info">
<h2 class="entry-title td-module-title"><a href="https://kenyannews.co.ke/news/is-messis-magic-wand-still-in-full-working-order/" rel="bookmark" title="Is Messi’s magic wand still in full working order?">Is Messi’s magic wand still in full working order?</a></h2>
<div class="td-editor-date">
<span class="td-author-date">
</span>
</div>
</div>
</div>
</div>
<div class="tdb_module_header tdb_module_mm td_module_wrap td-animation-stack td-meta-info-hide td-cpt-post">
<div class="td-module-container td-category-pos-image">
<div class="td-image-container">
<div class="td-module-thumb"><a href="https://kenyannews.co.ke/news/county-news/raila-leads-in-four-counties-ruto-ahead-in-one/" rel="bookmark" class="td-image-wrap " title="Raila leads in four counties, Ruto ahead in one"><span data-bg="" class="entry-thumb td-thumb-css rocket-lazyload" style=""></span></a></div> </div>
<div class="td-module-meta-info">
<h2 class="entry-title td-module-title"><a href="https://kenyannews.co.ke/news/county-news/raila-leads-in-four-counties-ruto-ahead-in-one/" rel="bookmark" title="Raila leads in four counties, Ruto ahead in one">Raila leads in four counties, Ruto ahead in one</a></h2>
<div class="td-editor-date">
<span class="td-author-date">
</span>
</div>
</div>
</div>
</div>
<div class="tdb_module_header tdb_module_mm td_module_wrap td-animation-stack td-meta-info-hide td-cpt-post">
<div class="td-module-container td-category-pos-image">
<div class="td-image-container">
<div class="td-module-thumb"><a href="https://kenyannews.co.ke/news/county-news/nakuru-becomes-second-county-with-many-municipalities/" rel="bookmark" class="td-image-wrap " title="Nakuru becomes second county with many municipalities"><span data-bg="" class="entry-thumb td-thumb-css rocket-lazyload" style=""></span></a></div> </div>
<div class="td-module-meta-info">
<h2 class="entry-title td-module-title"><a href="https://kenyannews.co.ke/news/county-news/nakuru-becomes-second-county-with-many-municipalities/" rel="bookmark" title="Nakuru becomes second county with many municipalities">Nakuru becomes second county with many municipalities</a></h2>
<div class="td-editor-date">
<span class="td-author-date">
</span>
</div>
</div>
</div>
</div>
</div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" aria-label="prev-page" id="prev-page-tdi_28" data-td_block_id="tdi_28"><i class="td-next-prev-icon td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" aria-label="next-page" id="next-page-tdi_28" data-td_block_id="tdi_28"><i class="td-next-prev-icon td-icon-font td-icon-menu-right"></i></a></div></div></div> </div></li>
</ul>
</li>
</ul><div class="tdb-menu-items-dropdown"><div class="td-subcat-more"><span class="tdb-menu-item-text">More</span><i class="tdb-menu-more-subicon td-icon-pluss tdb-main-sub-menu-icon"></i><ul class="td-pulldown-filter-list"></ul></div></div></div></div></div></div></div><div class="vc_column tdi_37  wpb_column vc_column_container tdc-column td-pb-span4">
<style scoped></style><div class="wpb_wrapper"><div class="td_block_wrap tdb_header_search tdi_38 tdb-header-search-trigger-enabled td-pb-border-top td-reel-news-header-search td_block_template_1 tdb-header-align" data-td-block-uid="tdi_38">
<style></style>
<style></style><div class="tdb-block-inner td-fix-index"><div class="tdb-drop-down-search" aria-labelledby="td-header-search-button"><div class="tdb-drop-down-search-inner"><form method="get" class="tdb-search-form" action="https://kenyannews.co.ke/"><div class="tdb-search-form-inner"><input class="tdb-head-search-form-input" placeholder=" " type="text" value="" name="s" autocomplete="off" /><input type="hidden" value="post" name="post_type" /><button class="wpb_button wpb_btn-inverse btn tdb-head-search-form-btn" type="submit"><span>Search</span></button></div></form><div class="tdb-aj-search"></div></div></div><a href="#" role="button" aria-label="Search" class="tdb-head-search-btn dropdown-toggle" data-toggle="dropdown"><i class="tdb-search-icon td-icon-search"></i></a></div></div> <div class="td_block_wrap tds_menu_login tdi_39  td-reel-news-menu-login td_block_template_1" data-td-block-uid="tdi_39">
<style></style>
<style></style><script>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</script><div id=tdi_39 class="tdw-block-inner"><div class="tdw-wml-wrap"><div class="tdw-wml-link tdw-wml-popup"><div class="tdw-wml-icon-wrap"><i class="tdw-wml-icon td-icon-profile"></i></div><span class="tdw-wml-user">My account</span></div><div class="tdw-wml-menu tdw-wml-guest"><div class="tdw-wml-menu-inner"><div class="tdw-wml-menu-header">Get into your account.</div><div class="tdw-wml-menu-content"><a class="tdw-wml-login-link tdw-wml-popup" href="https://kenyannews.co.ke/tds-my-account/">Login</a><a class="tdw-wml-register-link tdw-wml-popup" href="https://kenyannews.co.ke/tds-login-register/?signup">Register</a></div></div></div></div></div></div> <div class="tdm_block td_block_wrap td_block_wrap tdm_block_popup tdi_40 td-pb-border-top td_block_template_1" data-td-block-uid="tdi_40">
<style></style>
<style></style><script>var block_tdi_40 = new tdBlock();
block_tdi_40.id = "tdi_40";
block_tdi_40.atts = '{"button_size":"tdm-btn-lg","modal_align":"center-center","overlay_bg":"rgba(0,0,0,0.85)","modal_id":"td_m_7530","tdc_css":"eyJhbGwiOnsibWFyZ2luLWJvdHRvbSI6IjAiLCJtYXJnaW4tbGVmdCI6IjI0IiwiZGlzcGxheSI6IiJ9LCJsYW5kc2NhcGUiOnsibWFyZ2luLXRvcCI6Ii0zIiwibWFyZ2luLWxlZnQiOiIyMCIsImRpc3BsYXkiOiIifSwibGFuZHNjYXBlX21heF93aWR0aCI6MTE0MCwibGFuZHNjYXBlX21pbl93aWR0aCI6MTAxOSwicG9ydHJhaXQiOnsibWFyZ2luLWxlZnQiOiIxNiIsImRpc3BsYXkiOiIifSwicG9ydHJhaXRfbWF4X3dpZHRoIjoxMDE4LCJwb3J0cmFpdF9taW5fd2lkdGgiOjc2OH0=","trigg_btn_enable":"yes","tds_button":"tds_button5","button_tdicon":"td-icon-mail","tds_button5-text_color":"var(--reel-news-white)","button_icon_space":"0","button_icon_size":"eyJhbGwiOiIyMiIsImxhbmRzY2FwZSI6IjIwIiwicG9ydHJhaXQiOiIxOCJ9","tds_button5-text_hover_color":"var(--reel-news-white)","page_id":"417","all_head_border":"0","header_pos":"over-content","modal_bg":"var(--reel-news-accent)","modal_shadow_shadow_size":"0","modal_border_radius":"16","body_padd":"0","modal_width":"600","head_icon_color":"var(--reel-news-light-grey)","head_padd":"30px 40px 0 0","head_icon_color_h":"var(--reel-news-white)","block_type":"tdm_block_popup","show_modal_composer":"","separator":"","content_source":"page","custom_code":"","button_text":"","button_url":"","button_open_in_new_window":"","button_url_rel":"","button_icon_position":"","icon_align":"0","button_width":"","button_padding":"","btn_display":"","btn_float_right":"","btn_align_horiz":"content-horiz-left","ga_event_action":"","ga_event_category":"","ga_event_label":"","fb_pixel_event_name":"","fb_pixel_event_content_name":"","trigg_page_load_enable":"","modal_open_delay":"","modal_close_after":"","modal_prevent_open":"","trigg_cursor_area_enable":"","area_vertical_space":"200","modal_area_prevent_open":"","trigg_scroll_enable":"","scroll_distance":"","modal_scroll_prevent_open":"","open_position":"over-screen","modal_transition":"","site_scroll":"","modal_height":"","all_modal_border":"","all_modal_border_style":"solid","head_title":"","head_tdicon":"","head_icon_size":"","head_icon_align":"0","all_head_border_style":"solid","all_modal_border_color":"","modal_shadow_shadow_header":"","modal_shadow_shadow_title":"Modal shadow","modal_shadow_shadow_offset_horizontal":"","modal_shadow_shadow_offset_vertical":"","modal_shadow_shadow_spread":"","modal_shadow_shadow_color":"","head_title_color":"","head_bg":"","all_head_border_color":"","f_head_font_header":"","f_head_font_title":"Header title text","f_head_font_settings":"","f_head_font_family":"","f_head_font_size":"","f_head_font_line_height":"","f_head_font_style":"","f_head_font_weight":"","f_head_font_transform":"","f_head_font_spacing":"","f_head_":"","body_bg":"","el_class":"","css":"","block_template_id":"","td_column_number":1,"header_color":"","ajax_pagination_infinite_stop":"","offset":"","limit":"5","td_ajax_preloading":"","td_ajax_filter_type":"","td_filter_default_txt":"","td_ajax_filter_ids":"","color_preset":"","ajax_pagination":"","ajax_pagination_next_prev_swipe":"","border_top":"","class":"tdi_40","tdc_css_class":"tdi_40","tdc_css_class_style":"tdi_40_rand_style"}';
block_tdi_40.td_column_number = "1";
block_tdi_40.block_type = "tdm_block_popup";
block_tdi_40.post_count = "5";
block_tdi_40.found_posts = "5943";
block_tdi_40.header_color = "";
block_tdi_40.ajax_pagination_infinite_stop = "";
block_tdi_40.max_num_pages = "1189";
tdBlocksArray.push(block_tdi_40);
</script>
<style></style><div class="tds-button td-fix-index"><a href="#" class="tds-button5 tdm-btn tdm-btn-lg tdi_41"><span class="tdm-btn-text"></span><i class="tdm-btn-icon td-icon-mail"></i></a></div></div></div></div></div></div><div id="tdi_42" class="tdc-row"><div class="vc_row tdi_43  wpb_row td-pb-row">
<style scoped></style><div class="vc_column tdi_45  wpb_column vc_column_container tdc-column td-pb-span12">
<style scoped></style><div class="wpb_wrapper"><div class="td_block_wrap td_block_raw_css tdi_46 td-pb-border-top td_block_template_1" data-td-block-uid="tdi_46"><div id=tdi_46 class="td_block_inner td-fix-index"><style></style></div></div></div></div></div></div></div></div> </div>
<div class="td-header-desktop-sticky-wrap tdc-zone-sticky-invisible tdc-zone-sticky-inactive" style="display: none">
<div id="tdi_47" class="tdc-zone"><div class="tdc_zone tdi_48  wpb_row td-pb-row" data-sticky-offset="0">
<style scoped></style><div id="tdi_49" class="tdc-row"><div class="vc_row tdi_50  wpb_row td-pb-row">
<style scoped></style><div class="vc_column tdi_52  wpb_column vc_column_container tdc-column td-pb-span12">
<style scoped></style><div class="wpb_wrapper"></div></div></div></div></div></div> </div>
</div>
<div id="tdb-autoload-article" data-autoload="off" data-autoload-org-post-id="914448" data-autoload-type="" data-autoload-count="5">
<style></style>
<div class="td-main-content-wrap td-container-wrap">
<div class="tdc-content-wrap">
<article id="template-id-224827" class="post-224827 tdb_templates type-tdb_templates status-publish post">
<div id="tdi_53" class="tdc-zone"><div class="tdc_zone tdi_54  wpb_row td-pb-row">
<style scoped></style><div id="tdi_55" class="tdc-row"><div class="vc_row tdi_56  wpb_row td-pb-row">
<style scoped></style><div class="vc_column tdi_58  wpb_column vc_column_container tdc-column td-pb-span12">
<style scoped></style><div class="wpb_wrapper"><div class="td_block_wrap tdb_breadcrumbs tdi_59 td-pb-border-top td_block_template_1 tdb-breadcrumbs " data-td-block-uid="tdi_59">
<style></style><div class="tdb-block-inner td-fix-index"><span><a title="" class="tdb-entry-crumb" href="https://kenyannews.co.ke/">Home</a></span><i class="tdb-bread-sep td-icon-right"></i><span><a title="View all posts in TV" class="tdb-entry-crumb" href="https://kenyannews.co.ke/tv/">TV</a></span><i class="tdb-bread-sep tdb-bred-no-url-last td-icon-right"></i><span class="tdb-bred-no-url-last">Ramogi TV live</span></div></div><script type="application/ld+json">
                        {
                            "@context": "http://schema.org",
                            "@type": "BreadcrumbList",
                            "itemListElement": [{
                            "@type": "ListItem",
                            "position": 1,
                                "item": {
                                "@type": "WebSite",
                                "@id": "https://kenyannews.co.ke/",
                                "name": "Home"                                               
                            }
                        },{
                            "@type": "ListItem",
                            "position": 2,
                                "item": {
                                "@type": "WebPage",
                                "@id": "https://kenyannews.co.ke/tv/",
                                "name": "TV"
                            }
                        },{
                            "@type": "ListItem",
                            "position": 3,
                                "item": {
                                "@type": "WebPage",
                                "@id": "",
                                "name": "Ramogi TV live"                                
                            }
                        }    ]
                        }
                       </script></div></div></div></div><div id="tdi_60" class="tdc-row"><div class="vc_row tdi_61  wpb_row td-pb-row">
<style scoped></style><div class="vc_column tdi_63  wpb_column vc_column_container tdc-column td-pb-span12">
<style scoped></style><div class="wpb_wrapper"><div class="td_block_wrap tdb_single_categories tdi_64 td-pb-border-top td_block_template_1 " data-td-block-uid="tdi_64">
<style></style><div class="tdb-category td-fix-index"><a class="tdb-entry-category" href="https://kenyannews.co.ke/tv/"><span class="tdb-cat-bg"></span>TV</a></div></div></div></div></div></div><div id="tdi_65" class="tdc-row"><div class="vc_row tdi_66 td-ss-row wpb_row td-pb-row">
<style scoped></style><div class="vc_column tdi_68  wpb_column vc_column_container tdc-column td-pb-span8">
<style scoped></style><div class="wpb_wrapper"><div class="td_block_wrap tdb_title tdi_69 tdb-single-title td-pb-border-top td_block_template_1" data-td-block-uid="tdi_69">
<style></style><div class="tdb-block-inner td-fix-index"><h1 class="tdb-title-text">Ramogi TV live</h1><div></div><div class="tdb-title-line"></div></div></div><div class="td_block_wrap tdb_single_content tdi_71 td-pb-border-top td_block_template_1 td-post-content tagdiv-type" data-td-block-uid="tdi_71">
<style></style><div class="tdb-block-inner td-fix-index"><div class="td-a-ad id_inline_ad0 id_ad_content-horiz-center"><span class="td-adspot-title"></span><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-3264247487734791" data-ad-slot="9019890846" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div><p>Ramogi TV live stream. Kenya&#8217;s Premier Dholuo TV Station.</p>
<div id="beez_fixed_nw"></div>
<div id="beez_fixed">
<div class='player_responsive'>
<video id="player_1997189775" class="video-js vjs-default-skin vjs-big-play-centered" width="100%" height="400" preload="auto" poster="" autoplay controls playsInline data-setup='{}'>
<source src="https://74937-castr.akamaized.net/5ea49827ff3b5d7b22708777/live_9b761ff063f511eca12909b8ef1524b4/tracks-v1a1/mono.m3u8" label="" type="application/x-mpegURL">
</video>
</div>
</div>
</div></div><div class="wpb_wrapper td_block_separator td_block_wrap vc_separator tdi_73  td_separator_solid td_separator_center"><span style="border-color:#EBEBEB;border-width:1px;width:100%;"></span>
<style scoped></style></div><div class="td_block_wrap tdb_single_post_share tdi_74 td-pb-border-top td_block_template_1" data-td-block-uid="tdi_74">
<style></style><div id="tdi_74" class="td-post-sharing tdb-block td-ps-bg td-ps-notext td-post-sharing-style1 ">
<style></style>
<div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fkenyannews.co.ke%2Ftv%2Framogi-tv-live%2F" title="Facebook"><div class="td-social-but-icon"><i class="td-icon-facebook"></i></div><div class="td-social-but-text">Facebook</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Ramogi+TV+live&url=https%3A%2F%2Fkenyannews.co.ke%2Ftv%2Framogi-tv-live%2F&via=kenyannews_" title="Twitter"><div class="td-social-but-icon"><i class="td-icon-twitter"></i></div><div class="td-social-but-text">Twitter</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="https://api.whatsapp.com/send?text=Ramogi+TV+live %0A%0A https://kenyannews.co.ke/tv/ramogi-tv-live/" title="WhatsApp"><div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div><div class="td-social-but-text">WhatsApp</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-telegram" href="https://telegram.me/share/url?url=https://kenyannews.co.ke/tv/ramogi-tv-live/&text=Ramogi+TV+live" title="Telegram"><div class="td-social-but-icon"><i class="td-icon-telegram"></i></div><div class="td-social-but-text">Telegram</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-mail" href="/cdn-cgi/l/email-protection#9ca3efe9fef6f9ffe8a1cefdf1f3fbf5bcc8cabcf0f5eaf9bafef3f8e5a1f4e8e8ecefa6b3b3f7f9f2e5fdf2f2f9ebefb2fff3b2f7f9b3e8eab3eefdf1f3fbf5b1e8eab1f0f5eaf9b3" title="Email"><div class="td-social-but-icon"><i class="td-icon-mail"></i></div><div class="td-social-but-text">Email</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-print" href="#" title="Print"><div class="td-social-but-icon"><i class="td-icon-print"></i></div><div class="td-social-but-text">Print</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://kenyannews.co.ke/tv/ramogi-tv-live/&amp;media=https://kenyannews.co.ke/wp-content/uploads/2022/10/ramogitv.jpg&description=Ramogi+TV+live" title="Pinterest"><div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div><div class="td-social-but-text">Pinterest</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-linkedin" href="https://www.linkedin.com/shareArticle?mini=true&url=https://kenyannews.co.ke/tv/ramogi-tv-live/&title=Ramogi+TV+live" title="Linkedin"><div class="td-social-but-icon"><i class="td-icon-linkedin"></i></div><div class="td-social-but-text">Linkedin</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-reddit" href="https://reddit.com/submit?url=https://kenyannews.co.ke/tv/ramogi-tv-live/&title=Ramogi+TV+live" title="ReddIt"><div class="td-social-but-icon"><i class="td-icon-reddit"></i></div><div class="td-social-but-text">ReddIt</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-tumblr" href="https://www.tumblr.com/share/link?url=https://kenyannews.co.ke/tv/ramogi-tv-live/&name=Ramogi TV live" title="Tumblr"><div class="td-social-but-icon"><i class="td-icon-tumblr"></i></div><div class="td-social-but-text">Tumblr</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-stumbleupon" href="https://www.mix.com/add?url=https://kenyannews.co.ke/tv/ramogi-tv-live/" title="Mix"><div class="td-social-but-icon"><i class="td-icon-stumbleupon"></i></div><div class="td-social-but-text">Mix</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-vk" href="https://vk.com/share.php?url=https://kenyannews.co.ke/tv/ramogi-tv-live/" title="VK"><div class="td-social-but-icon"><i class="td-icon-vk"></i></div><div class="td-social-but-text">VK</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-digg" href="https://www.digg.com/submit?url=https://kenyannews.co.ke/tv/ramogi-tv-live/" title="Digg"><div class="td-social-but-icon"><i class="td-icon-digg"></i></div><div class="td-social-but-text">Digg</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-line" href="https://line.me/R/msg/text/?Ramogi+TV+live%0D%0Ahttps://kenyannews.co.ke/tv/ramogi-tv-live/" title="LINE"><div class="td-social-but-icon"><i class="td-icon-line"></i></div><div class="td-social-but-text">LINE</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-viber" href="viber://forward?text=Ramogi+TV+live https://kenyannews.co.ke/tv/ramogi-tv-live/" title="Viber"><div class="td-social-but-icon"><i class="td-icon-viber"></i></div><div class="td-social-but-text">Viber</div></a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="tdi_74" title="More">
<div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
</a></div></div></div><div class="wpb_wrapper td_block_separator td_block_wrap vc_separator tdi_76  td_separator_solid td_separator_center"><span style="border-color:#EBEBEB;border-width:1px;width:100%;"></span>
<style scoped></style></div><div class="td_block_wrap tdb_single_related tdi_77 td_with_ajax_pagination td-pb-border-top td_block_template_1 tdb-single-related-posts" data-td-block-uid="tdi_77">
<style></style>
<style></style><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>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</script><div class="td-block-title-wrap"><h4 class="block-title"><span>RELATED RADIO STATIONS</span></h4></div><div id=tdi_77 class="td_block_inner tdb-block-inner td-fix-index">
<div class="tdb_module_related td_module_wrap td-animation-stack td-meta-info-hide">
<div class="td-module-container td-category-pos-image">
<div class="td-image-container">
<a href="https://kenyannews.co.ke/tv/" class="td-post-category">TV</a> <div class="td-module-thumb"><a href="https://kenyannews.co.ke/tv/aljazeera-live-stream/" rel="bookmark" class="td-image-wrap " title="Aljazeera Live stream"><span data-bg="https://kenyannews.co.ke/wp-content/uploads/2022/07/hq720-3-696x391.webp" class="entry-thumb td-thumb-css rocket-lazyload" style=""></span><span class="td-video-play-ico"><i class="td-icon-video-thumb-play"></i></span></a></div> </div>
<div class="td-module-meta-info">
<h3 class="entry-title td-module-title"><a href="https://kenyannews.co.ke/tv/aljazeera-live-stream/" rel="bookmark" title="Aljazeera Live stream">Aljazeera Live stream</a></h3>
<div class="td-editor-date">
<span class="td-author-date">
</span>
</div>
</div>
</div>
</div>
<div class="tdb_module_related td_module_wrap td-animation-stack td-meta-info-hide">
<div class="td-module-container td-category-pos-image">
<div class="td-image-container">
<a href="https://kenyannews.co.ke/tv/" class="td-post-category">TV</a> <div class="td-module-thumb"><a href="https://kenyannews.co.ke/tv/metropol-tv-kenya/" rel="bookmark" class="td-image-wrap " title="Metropol tv live"><span data-bg="https://kenyannews.co.ke/wp-content/uploads/2022/07/unnamed.jpg" class="entry-thumb td-thumb-css rocket-lazyload" style=""></span><span class="td-video-play-ico"><i class="td-icon-video-thumb-play"></i></span></a></div> </div>
<div class="td-module-meta-info">
<h3 class="entry-title td-module-title"><a href="https://kenyannews.co.ke/tv/metropol-tv-kenya/" rel="bookmark" title="Metropol tv live">Metropol tv live</a></h3>
<div class="td-editor-date">
<span class="td-author-date">
</span>
</div>
</div>
</div>
</div>
<div class="tdb_module_related td_module_wrap td-animation-stack td-meta-info-hide">
<div class="td-module-container td-category-pos-image">
<div class="td-image-container">
<a href="https://kenyannews.co.ke/tv/" class="td-post-category">TV</a> <div class="td-module-thumb"><a href="https://kenyannews.co.ke/tv/tv47/" rel="bookmark" class="td-image-wrap " title="TV47 live"><span data-bg="https://kenyannews.co.ke/wp-content/uploads/2022/07/channels4_profile.jpg" class="entry-thumb td-thumb-css rocket-lazyload" style=""></span><span class="td-video-play-ico"><i class="td-icon-video-thumb-play"></i></span></a></div> </div>
<div class="td-module-meta-info">
<h3 class="entry-title td-module-title"><a href="https://kenyannews.co.ke/tv/tv47/" rel="bookmark" title="TV47 live">TV47 live</a></h3>
<div class="td-editor-date">
<span class="td-author-date">
</span>
</div>
</div>
</div>
</div>
<div class="tdb_module_related td_module_wrap td-animation-stack td-meta-info-hide">
<div class="td-module-container td-category-pos-image">
<div class="td-image-container">
<a href="https://kenyannews.co.ke/tv/" class="td-post-category">TV</a> <div class="td-module-thumb"><a href="https://kenyannews.co.ke/tv/family-tv/" rel="bookmark" class="td-image-wrap " title="Family Tv live"><span data-bg="https://kenyannews.co.ke/wp-content/uploads/2022/07/unnamed-1.jpg" class="entry-thumb td-thumb-css rocket-lazyload" style=""></span><span class="td-video-play-ico"><i class="td-icon-video-thumb-play"></i></span></a></div> </div>
<div class="td-module-meta-info">
<h3 class="entry-title td-module-title"><a href="https://kenyannews.co.ke/tv/family-tv/" rel="bookmark" title="Family Tv live">Family Tv live</a></h3>
<div class="td-editor-date">
<span class="td-author-date">
</span>
</div>
</div>
</div>
</div>
<div class="tdb_module_related td_module_wrap td-animation-stack td-meta-info-hide">
<div class="td-module-container td-category-pos-image">
<div class="td-image-container">
<a href="https://kenyannews.co.ke/tv/" class="td-post-category">TV</a> <div class="td-module-thumb"><a href="https://kenyannews.co.ke/tv/citizen-tv/" rel="bookmark" class="td-image-wrap " title="Citizen TV live"><span data-bg="https://kenyannews.co.ke/wp-content/uploads/2022/07/hq720-696x391.webp" class="entry-thumb td-thumb-css rocket-lazyload" style=""></span><span class="td-video-play-ico"><i class="td-icon-video-thumb-play"></i></span></a></div> </div>
<div class="td-module-meta-info">
<h3 class="entry-title td-module-title"><a href="https://kenyannews.co.ke/tv/citizen-tv/" rel="bookmark" title="Citizen TV live">Citizen TV live</a></h3>
<div class="td-editor-date">
<span class="td-author-date">
</span>
</div>
</div>
</div>
</div>
<div class="tdb_module_related td_module_wrap td-animation-stack td-meta-info-hide">
<div class="td-module-container td-category-pos-image">
<div class="td-image-container">
<a href="https://kenyannews.co.ke/tv/" class="td-post-category">TV</a> <div class="td-module-thumb"><a href="https://kenyannews.co.ke/tv/ktn-news/" rel="bookmark" class="td-image-wrap " title="KTN News live"><span data-bg="https://kenyannews.co.ke/wp-content/uploads/2022/07/hqdefault.webp" class="entry-thumb td-thumb-css rocket-lazyload" style=""></span><span class="td-video-play-ico"><i class="td-icon-video-thumb-play"></i></span></a></div> </div>
<div class="td-module-meta-info">
<h3 class="entry-title td-module-title"><a href="https://kenyannews.co.ke/tv/ktn-news/" rel="bookmark" title="KTN News live">KTN News live</a></h3>
<div class="td-editor-date">
<span class="td-author-date">
</span>
</div>
</div>
</div>
</div>
<div class="tdb_module_related td_module_wrap td-animation-stack td-meta-info-hide">
<div class="td-module-container td-category-pos-image">
<div class="td-image-container">
<a href="https://kenyannews.co.ke/tv/" class="td-post-category">TV</a> <div class="td-module-thumb"><a href="https://kenyannews.co.ke/tv/ntv-kenya/" rel="bookmark" class="td-image-wrap " title="NTV Kenya live"><span data-bg="https://kenyannews.co.ke/wp-content/uploads/2022/07/hq720-1-696x391.webp" class="entry-thumb td-thumb-css rocket-lazyload" style=""></span><span class="td-video-play-ico"><i class="td-icon-video-thumb-play"></i></span></a></div> </div>
<div class="td-module-meta-info">
<h3 class="entry-title td-module-title"><a href="https://kenyannews.co.ke/tv/ntv-kenya/" rel="bookmark" title="NTV Kenya live">NTV Kenya live</a></h3>
<div class="td-editor-date">
<span class="td-author-date">
</span>
</div>
</div>
</div>
</div>
<div class="tdb_module_related td_module_wrap td-animation-stack td-meta-info-hide">
<div class="td-module-container td-category-pos-image">
<div class="td-image-container">
<a href="https://kenyannews.co.ke/tv/" class="td-post-category">TV</a> <div class="td-module-thumb"><a href="https://kenyannews.co.ke/tv/ktn-home/" rel="bookmark" class="td-image-wrap " title="KTN Home live"><span data-bg="https://kenyannews.co.ke/wp-content/uploads/2022/07/hq720-5-696x391.webp" class="entry-thumb td-thumb-css rocket-lazyload" style=""></span><span class="td-video-play-ico"><i class="td-icon-video-thumb-play"></i></span></a></div> </div>
<div class="td-module-meta-info">
<h3 class="entry-title td-module-title"><a href="https://kenyannews.co.ke/tv/ktn-home/" rel="bookmark" title="KTN Home live">KTN Home live</a></h3>
<div class="td-editor-date">
<span class="td-author-date">
</span>
</div>
</div>
</div>
</div>
</div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" aria-label="prev-page" id="prev-page-tdi_77" data-td_block_id="tdi_77"><i class="td-next-prev-icon td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" aria-label="next-page" id="next-page-tdi_77" data-td_block_id="tdi_77"><i class="td-next-prev-icon td-icon-font td-icon-menu-right"></i></a></div></div><div class="td-block td-a-rec td-a-rec-id-custom-spot tdi_78 td_block_template_1">
<style></style>
<style></style><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-3264247487734791" data-ad-slot="5563019613"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div></div><div class="vc_column tdi_80  wpb_column vc_column_container tdc-column td-pb-span4">
<style scoped></style><div class="wpb_wrapper"><div class="td-block td-a-rec td-a-rec-id-custom-spot tdi_81 td_block_template_1">
<style></style>
<style></style><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-3264247487734791" data-ad-slot="6967719488" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div><div class="td-block td-a-rec td-a-rec-id-custom-spot tdi_82 td_block_template_1">
<style></style>
<style></style><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-3264247487734791" data-ad-slot="5563019613"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div><div class="td-block td-a-rec td-a-rec-id-custom-spot tdi_83 td_block_template_1">
<style></style><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-5011174329758173" data-ad-slot="4389094548" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div></div></div></div></div></div> </article>
</div>
</div>
</div> 
<div class="td-footer-template-wrap" style="position: relative">
<div class="td-footer-wrap ">
<div id="tdi_84" class="tdc-zone"><div class="tdc_zone tdi_85  wpb_row td-pb-row tdc-element-style">
<style scoped></style>
<div class="tdi_84_rand_style td-element-style"><style></style></div><div id="tdi_86" class="tdc-row"><div class="vc_row tdi_87  wpb_row td-pb-row">
<style scoped></style><div class="vc_column tdi_89  wpb_column vc_column_container tdc-column td-pb-span4">
<style scoped></style><div class="wpb_wrapper"><div class="td_block_wrap tdb_header_logo tdi_90 td-pb-border-top td_block_template_1 tdb-header-align" data-td-block-uid="tdi_90">
<style></style>
<style></style><div class="tdb-block-inner td-fix-index"><a class="tdb-logo-a" href="https://kenyannews.co.ke/"><span class="tdb-logo-text-wrap"><span class="tdb-logo-text-title">KenyanNews</span></span></a></div></div> <div class="tdm_block td_block_wrap tdm_block_inline_text tdi_91 td-pb-border-top td_block_template_1" data-td-block-uid="tdi_91">
<style></style>
<style></style><p class="tdm-descr">Here we have all the most popular Tv and radio stations in Kenya. Watch and Listen to Radio Online for free on your device. Quickly! Comfortable! Easy!
Current news and information.</p></div><div class="tdm_block td_block_wrap tdm_block_socials tdi_92 tdm-content-horiz-left td-pb-border-top td_block_template_1" data-td-block-uid="tdi_92">
<style></style>
<style></style>
<style></style><div class="tdm-social-wrapper tds-social1 tdi_93"><div class="tdm-social-item-wrap"><a href="https://www.facebook.com/kenyannews.co.ke" target="_blank" title="Facebook" class="tdm-social-item"><i class="td-icon-font td-icon-facebook"></i></a><a href="https://www.facebook.com/kenyannews.co.ke" target="_blank" class="tdm-social-text">Facebook</a></div><div class="tdm-social-item-wrap"><a href="https://www.instagram.com/kenyannews.co.ke/" target="_blank" title="Instagram" class="tdm-social-item"><i class="td-icon-font td-icon-instagram"></i></a><a href="https://www.instagram.com/kenyannews.co.ke/" target="_blank" class="tdm-social-text">Instagram</a></div><div class="tdm-social-item-wrap"><a href="#" target="_blank" title="TikTok" class="tdm-social-item"><i class="td-icon-font td-icon-tiktok"></i></a><a href="#" target="_blank" class="tdm-social-text">TikTok</a></div><div class="tdm-social-item-wrap"><a href="https://twitter.com/kenyannews_" target="_blank" title="Twitter" class="tdm-social-item"><i class="td-icon-font td-icon-twitter"></i></a><a href="https://twitter.com/kenyannews_" target="_blank" class="tdm-social-text">Twitter</a></div></div></div></div></div><div class="vc_column tdi_95  wpb_column vc_column_container tdc-column td-pb-span4">
<style scoped></style><div class="wpb_wrapper"><div class="td_block_wrap td_block_list_menu tdi_96 td-pb-border-top td_block_template_1 widget" data-td-block-uid="tdi_96">
<style></style>
<style></style><div class="td-block-title-wrap"></div><div id=tdi_96 class="td_block_inner td-fix-index"><div class="menu-sub-footer-container"><ul id="menu-sub-footer" class="menu"><li id="menu-item-5193" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5193"><a href="https://kenyannews.co.ke/about/">About</a></li>
<li id="menu-item-5194" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5194"><a href="https://kenyannews.co.ke/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-31013" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-31013"><a href="https://kenyannews.co.ke/disclaimer/">Disclaimer</a></li>
</ul></div></div></div><div class="td_block_wrap td_block_list_menu tdi_97 td-pb-border-top td_block_template_1 widget" data-td-block-uid="tdi_97">
<style></style>
<style></style><div class="td-block-title-wrap"></div><div id=tdi_97 class="td_block_inner td-fix-index"><div class="menu-top-header-container"><ul id="menu-top-header" class="menu"><li id="menu-item-5195" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5195"><a href="https://kenyannews.co.ke/advertise/">Advertise</a></li>
<li id="menu-item-5196" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5196"><a href="https://kenyannews.co.ke/contact-us/">Contact Us</a></li>
</ul></div></div></div></div></div><div class="vc_column tdi_99  wpb_column vc_column_container tdc-column td-pb-span4">
<style scoped></style><div class="wpb_wrapper"><div class="td_block_wrap td_block_list_menu tdi_100 td-pb-border-top td_block_template_1 widget" data-td-block-uid="tdi_100">
<style></style>
<style></style><div class="td-block-title-wrap"></div><div id=tdi_100 class="td_block_inner td-fix-index"><div class="menu-footer-container"><ul id="menu-footer-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-913825"><a href="https://kenyannews.co.ke/tv/">TV</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-radio_country menu-item-914249"><a href="https://kenyannews.co.ke/country/ke/">Radio stations</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-913826"><a href="https://kenyannews.co.ke/news/">News</a></li>
</ul></div></div></div></div></div></div></div><div id="tdi_101" class="tdc-row"><div class="vc_row tdi_102  wpb_row td-pb-row">
<style scoped></style><div class="vc_column tdi_104  wpb_column vc_column_container tdc-column td-pb-span12">
<style scoped></style><div class="wpb_wrapper"><div class="tdm_block td_block_wrap tdm_block_inline_text tdi_105 td-pb-border-top td_block_template_1" data-td-block-uid="tdi_105">
<style></style>
<style></style><p class="tdm-descr">© kenyannews.co.ke. All Rights Reserved.</p></div></div></div></div></div></div></div> </div>
</div>
<style></style>
</div>
<div class="wp-radio-player align-center full-width init-hidden ">

<div class="wp-radio-player-details">
<a href="" class="station-thumbnail-wrap">
<img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" class="station-thumbnail" alt="WP Radio" data-lazy-src="https://kenyannews.co.ke/wp-content/plugins/wp-radio-premium/assets/images/placeholder.jpg" /><noscript><img src="https://kenyannews.co.ke/wp-content/plugins/wp-radio-premium/assets/images/placeholder.jpg" class="station-thumbnail"
                 alt="WP Radio"/></noscript>
</a>
<div class="station-meta">
<a href="" class="station-title">WP Radio</a>

<div class="station-status">
<div class="wp-radio-player-status status-">
<span class="status-text-offline">OFFLINE</span>
<span class="status-text-live">LIVE</span>
<span class="status-dot"></span>
</div>

<div class="wp-radio-player-song-title" data-id=""></div>
</div>
</div>
</div>

<div class="wp-radio-player-controls">

<button type="button" class="play-prev" aria-label="Play Previous" title="Play Previous">
<span class="dashicons dashicons-controls-skipback"></span>
</button>

<button type="button" aria-label="Play/Pause" title="Play/Pause" class="play-btn" data-id="">
<div class="wp-radio-spinner">
<div></div>
<div></div>
<div></div>
<div></div>
<div></div>
<div></div>
<div></div>
</div>
<span class="dashicons dashicons-controls-play"></span>
<span class="dashicons dashicons-controls-pause"></span>
</button>

<button type="button" class="play-next" aria-label="Play Next" title="Play Next">
<span class="dashicons dashicons-controls-skipforward"></span>
</button>

<button type="button" class="player-popup" aria-label="Open popup player" title="Open popup player">
<span class="dashicons dashicons-external"></span>
</button>

<div class="player-volume-wrap">
<div class="volume-slider">
<div class="volume-slider-bar">
<div class="volume-slider-handle"></div>
</div>
<input type="range" min="0" max="100" value="100" step="1">
</div>
<button type="button" class="player-volume">
<i class="dashicons dashicons-controls-volumeon"></i>
</button>
</div>
</div>

<div class="wp-radio-player-toggle">
<i class="dashicons dashicons-arrow-down-alt2" aria-label="Collapse player" title="Collapse player"></i>
<i class="dashicons dashicons-controls-play" aria-label="Expand player" title="Expand player"></i>
</div>
<audio id="wp-radio-media" src="" preload="none"></audio>
</div>


<style type="text/css" media="screen"></style>
<script type='text/javascript' id='wp-util-js-extra'>
/* <![CDATA[ */
var _wpUtilSettings = {"ajax":{"url":"\/wp-admin\/admin-ajax.php"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://kenyannews.co.ke/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=3.15.0' id='wp-polyfill-js'></script>
<script type='text/javascript' src='https://kenyannews.co.ke/wp-includes/js/dist/hooks.min.js?ver=c6d64f2cb8f5c6bb49caca37f8828ce3' id='wp-hooks-js'></script>
<script type='text/javascript' src='https://kenyannews.co.ke/wp-includes/js/dist/i18n.min.js?ver=ebee46757c6a411e38fd079a7ac71d94' id='wp-i18n-js'></script>
<script type='text/javascript' id='wp-radio-js-extra'>
/* <![CDATA[ */
var wpRadio = {"pluginUrl":"https:\/\/kenyannews.co.ke\/wp-content\/plugins\/wp-radio-premium","siteUrl":"https:\/\/kenyannews.co.ke","popupURL":"https:\/\/kenyannews.co.ke","nonce":"15ead4fad2","isPro":"1","settings":{"listing_thumbnail_size":"auto"}};
/* ]]> */
</script>
<script type='text/javascript' id='rocket-browser-checker-js-after'>
"use strict";var _createClass=function(){function defineProperties(target,props){for(var i=0;i<props.length;i++){var descriptor=props[i];descriptor.enumerable=descriptor.enumerable||!1,descriptor.configurable=!0,"value"in descriptor&&(descriptor.writable=!0),Object.defineProperty(target,descriptor.key,descriptor)}}return function(Constructor,protoProps,staticProps){return protoProps&&defineProperties(Constructor.prototype,protoProps),staticProps&&defineProperties(Constructor,staticProps),Constructor}}();function _classCallCheck(instance,Constructor){if(!(instance instanceof Constructor))throw new TypeError("Cannot call a class as a function")}var RocketBrowserCompatibilityChecker=function(){function RocketBrowserCompatibilityChecker(options){_classCallCheck(this,RocketBrowserCompatibilityChecker),this.passiveSupported=!1,this._checkPassiveOption(this),this.options=!!this.passiveSupported&&options}return _createClass(RocketBrowserCompatibilityChecker,[{key:"_checkPassiveOption",value:function(self){try{var options={get passive(){return!(self.passiveSupported=!0)}};window.addEventListener("test",null,options),window.removeEventListener("test",null,options)}catch(err){self.passiveSupported=!1}}},{key:"initRequestIdleCallback",value:function(){!1 in window&&(window.requestIdleCallback=function(cb){var start=Date.now();return setTimeout(function(){cb({didTimeout:!1,timeRemaining:function(){return Math.max(0,50-(Date.now()-start))}})},1)}),!1 in window&&(window.cancelIdleCallback=function(id){return clearTimeout(id)})}},{key:"isDataSaverModeOn",value:function(){return"connection"in navigator&&!0===navigator.connection.saveData}},{key:"supportsLinkPrefetch",value:function(){var elem=document.createElement("link");return elem.relList&&elem.relList.supports&&elem.relList.supports("prefetch")&&window.IntersectionObserver&&"isIntersecting"in IntersectionObserverEntry.prototype}},{key:"isSlowConnection",value:function(){return"connection"in navigator&&"effectiveType"in navigator.connection&&("2g"===navigator.connection.effectiveType||"slow-2g"===navigator.connection.effectiveType)}}]),RocketBrowserCompatibilityChecker}();
</script>
<script type='text/javascript' id='rocket-preload-links-js-extra'>
/* <![CDATA[ */
var RocketPreloadLinksConfig = {"excludeUris":"\/wp-admin(.*)|\/(?:.+\/)?feed(?:\/(?:.+\/?)?)?$|\/(?:.+\/)?embed\/|\/(index\\.php\/)?wp\\-json(\/.*|$)|\/refer\/|\/go\/|\/recommend\/|\/recommends\/","usesTrailingSlash":"1","imageExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif|pdf|doc|docx|xls|xlsx|php","fileExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif|pdf|doc|docx|xls|xlsx|php|html|htm","siteUrl":"https:\/\/kenyannews.co.ke","onHoverDelay":"100","rateThrottle":"3"};
/* ]]> */
</script>
<script type='text/javascript' id='rocket-preload-links-js-after'>
(function() {
"use strict";var r="function"==typeof Symbol&&"symbol"==typeof Symbol.iterator?function(e){return typeof e}:function(e){return e&&"function"==typeof Symbol&&e.constructor===Symbol&&e!==Symbol.prototype?"symbol":typeof e},e=function(){function i(e,t){for(var n=0;n<t.length;n++){var i=t[n];i.enumerable=i.enumerable||!1,i.configurable=!0,"value"in i&&(i.writable=!0),Object.defineProperty(e,i.key,i)}}return function(e,t,n){return t&&i(e.prototype,t),n&&i(e,n),e}}();function i(e,t){if(!(e instanceof t))throw new TypeError("Cannot call a class as a function")}var t=function(){function n(e,t){i(this,n),this.browser=e,this.config=t,this.options=this.browser.options,this.prefetched=new Set,this.eventTime=null,this.threshold=1111,this.numOnHover=0}return e(n,[{key:"init",value:function(){!this.browser.supportsLinkPrefetch()||this.browser.isDataSaverModeOn()||this.browser.isSlowConnection()||(this.regex={excludeUris:RegExp(this.config.excludeUris,"i"),images:RegExp(".("+this.config.imageExt+")$","i"),fileExt:RegExp(".("+this.config.fileExt+")$","i")},this._initListeners(this))}},{key:"_initListeners",value:function(e){-1<this.config.onHoverDelay&&document.addEventListener("mouseover",e.listener.bind(e),e.listenerOptions),document.addEventListener("mousedown",e.listener.bind(e),e.listenerOptions),document.addEventListener("touchstart",e.listener.bind(e),e.listenerOptions)}},{key:"listener",value:function(e){var t=e.target.closest("a"),n=this._prepareUrl(t);if(null!==n)switch(e.type){case"mousedown":case"touchstart":this._addPrefetchLink(n);break;case"mouseover":this._earlyPrefetch(t,n,"mouseout")}}},{key:"_earlyPrefetch",value:function(t,e,n){var i=this,r=setTimeout(function(){if(r=null,0===i.numOnHover)setTimeout(function(){return i.numOnHover=0},1e3);else if(i.numOnHover>i.config.rateThrottle)return;i.numOnHover++,i._addPrefetchLink(e)},this.config.onHoverDelay);t.addEventListener(n,function e(){t.removeEventListener(n,e,{passive:!0}),null!==r&&(clearTimeout(r),r=null)},{passive:!0})}},{key:"_addPrefetchLink",value:function(i){return this.prefetched.add(i.href),new Promise(function(e,t){var n=document.createElement("link");n.rel="prefetch",n.href=i.href,n.onload=e,n.onerror=t,document.head.appendChild(n)}).catch(function(){})}},{key:"_prepareUrl",value:function(e){if(null===e||"object"!==(void 0===e?"undefined":r(e))||!1 in e||-1===["http:","https:"].indexOf(e.protocol))return null;var t=e.href.substring(0,this.config.siteUrl.length),n=this._getPathname(e.href,t),i={original:e.href,protocol:e.protocol,origin:t,pathname:n,href:t+n};return this._isLinkOk(i)?i:null}},{key:"_getPathname",value:function(e,t){var n=t?e.substring(this.config.siteUrl.length):e;return n.startsWith("/")||(n="/"+n),this._shouldAddTrailingSlash(n)?n+"/":n}},{key:"_shouldAddTrailingSlash",value:function(e){return this.config.usesTrailingSlash&&!e.endsWith("/")&&!this.regex.fileExt.test(e)}},{key:"_isLinkOk",value:function(e){return null!==e&&"object"===(void 0===e?"undefined":r(e))&&(!this.prefetched.has(e.href)&&e.origin===this.config.siteUrl&&-1===e.href.indexOf("?")&&-1===e.href.indexOf("#")&&!this.regex.excludeUris.test(e.href)&&!this.regex.images.test(e.href))}}],[{key:"run",value:function(){"undefined"!=typeof RocketPreloadLinksConfig&&new n(new RocketBrowserCompatibilityChecker({capture:!0,passive:!0}),RocketPreloadLinksConfig).init()}}]),n}();t.run();
}());
</script>
<script type='text/javascript' id='tds_js_files_for_front-js-extra'>
/* <![CDATA[ */
var tds_js_globals = {"wpRestNonce":"15ead4fad2","wpRestUrl":"https:\/\/kenyannews.co.ke\/wp-json\/","permalinkStructure":"\/%category%\/%postname%\/"};
/* ]]> */
</script>
<amp-auto-ads type="adsense" data-ad-client="ca-pub-3264247487734791">
</amp-auto-ads>
<amp-auto-ads type="adsense" data-ad-client="ca-pub-5011174329758173">
</amp-auto-ads>

<script src='https://stats.wp.com/e-202241.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:11.4',blog:'113111616',post:'914448',tz:'3',srv:'kenyannews.co.ke'} ]);
	_stq.push([ 'clickTrackerInit', '113111616', '914448' ]);
</script>
<script>window.lazyLoadOptions=[{elements_selector:"img[data-lazy-src],.rocket-lazyload,iframe[data-lazy-src]",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}},{elements_selector:".rocket-lazyload",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,}];window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(var i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){continue}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){continue}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://kenyannews.co.ke/wp-content/plugins/wp-rocket/assets/js/lazyload/17.5/lazyload.min.js"></script>
<script src="https://kenyannews.co.ke/wp-content/cache/min/1/82c875bbe7b72b51ad22d92561a7e0e6.js" data-minify="1" defer></script><script>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</script></body>
</html>
